Your browser (Internet Explorer 6) is out of date. It has known security flaws and may not display all features of this and other websites. Learn how to update your browser.
X

Phoenix Viewer Release 1.5.2.908!

Phoenix Viewer Release 1.5.2.908 is out! There have been a lot of bug fixes and improvements on this version… It is definitely the version you want to be on!

Just a few of the many things we’ve fixed.
- Improved overall performance and stability!
- No more RLVa Assertion Failure errors!
- 42 group auto detection, no more tinkering with settings,  it just works!
- Showcase TP links have been fixed to work properly now for Windows & Mac, Linux in our next release.
- Updated Webkit helping webpages load faster in the web browser, improved memory handling etc. 
- The momentary viewer lockups experienced on 373, 725 and 818 should be a thing of the past.
- Texture jumping issues where textures load, then unload, load, then unload.. resolved!
- Updated Viewer tags are in this release. You’ll be able to see all the viewers out there more accurately
- Built in IRC client has been fixed! No more ??? ???  names in IRC rooms.
- Huge improvement to ‘De-render’, which now permanently de-renders items until they are removed from the Asset Blacklist.
- Skin downloader fixes
- Improved installer, no more downloading additional files during the install process.
- So much more!

This is ONE of the last Phoenix viewer releases we’ll be putting out, grab it while you can!

If you have any problems updating, please remember to contact our 24/7 Support Team for help!

Windows SSE:
http://downloads.phoenixviewer.com/windows/Phoenix_Viewer-1.5.2.908.exe

Windows SSE2:
http://downloads.phoenixviewer.com/windows/Phoenix_Viewer-1.5.2.908_SSE2.exe

Mac:
http://downloads.phoenixviewer.com/Mac/Phoenix_Viewer_1.5.2.908_Intel.dmg

Linux:
http://downloads.phoenixviewer.com/Linux/PhoenixViewer-i686-1.5.2.908.tar.bz2

The Phoenix Viewer Project, Inc.

  • oh darn i thought that the official Firestorm viewer was coming this weekend.
    When is that one coming? I’m so confused lol

    KEVINN Draconia

    February 13, 2011

  • I think they said the next alpha release of Firestorm was due on Feb 28

    Cincia

    February 13, 2011

  • The new release wont let me install it. Keeps giving me an error. Is there something special i need to do?

    skyefyre123

    February 13, 2011

  • love pheonix i JUST WISH that on the SL chat tabs that it would be down the left hand side like emergence and not at the bottom. FAR easier to see those who are IMMING you. perhaps that could be for the next release??

    Daisy Baily

    February 13, 2011

  • ok, i am having alpha texture issues with this….hair flickers madly.

    checking enable fast alpha reduces it, but doesnt eliminate it. anyone know of any debug settings?

    Thistle

    February 13, 2011

  • Daisy Baily said…
    love pheonix i JUST WISH that on the SL chat tabs that it would be down the left hand side like emergence and not at the bottom. FAR easier to see those who are IMMING you. perhaps that could be for the next release??

    its already been like that you just have to set it up that way through settings :O

    Misty

    February 13, 2011

  • ok…SL had me wearing two sets of hair, which i thought was impossible…..apparently not.

    fixed.

    Thistle

    February 13, 2011

  • Daisey you can have the im tabs down left side
    look in phoenix perfernces

    Cady

    February 13, 2011

  • How come there is no multilayer for tattoos on this updated viewer? =(

    Latinfaery

    February 13, 2011

  • I’m on a mac and it won’t let me install… keep getting an error notice ;_;

    Maribel

    February 13, 2011

  • After I downloaded and installed it and go to log in it just sits there and nothing happens…so what do i do to fix this? Anyone else have this problem?? :[

    Dazhean

    February 14, 2011

  • Okay, so I guess it had something to do with the region I had been in earlier. So it’s fixed. ^^

    Dazhean

    February 14, 2011

  • Are we getting clothing layering any time soon?

    Nate

    February 14, 2011

  • The clothing layer features will be on the firestorm viewer I believe, because that feature needs a viewer 2 based viewer to work. At least that’s my understanding.

    Danu Tungsten

    February 14, 2011

  • This comment has been removed by the author.

    Danu Tungsten

    February 14, 2011

  • i cant not log in help

    sherry

    February 14, 2011

  • Impressive work. I’ve to admit, I avoided Phoenix for long but after trying other TPVs and laboring with Viewer 2, this is the only viewer project, that makes me enjoy SL again. Support channels are always helpful, not only for geeks. Lets hope that LL will learn from you guys.

    Trin Trevellion

    February 14, 2011

  • Phoenix_Viewer-1.5.2.908_SSE2 don’t work, it say my Windows 7 Pro 64 Bit don’t support it.
    Maybe the SSE2 Version support just 32 Bit OS.
    I use a AMD Athlon II X4 620 who can use SSE, SSE2, SSE3, SSE4A after a scan with cpu-z.

    Tigra

    February 14, 2011

  • Opened it after installing.. and it crashed as soon as I Tped. I am reinstalling the older version. What ever fixes this version fixed, well it broke some things too.

    What I Think

    February 14, 2011

  • New viewer runs better :) thank you guys.

    Michael

    February 14, 2011

  • Installed .908 and it ran fine. It crashed at a busy shop during a new release frenzy and when I restarted 908 it crashed as soon as I moved (clearing cache didn’t help). Reinstalled again over top of the previous installation and all is fine again.

    Cincia

    February 14, 2011

  • Using OSX, it worked perfectly, thanks for the update!

    Logan

    February 14, 2011

  • Just to add my appreciation – not only is .908 a brilliant viewer (I downloaded yesterday once the server was able to breathe and installed this morning. Also to the best support tream in SL. Also for producing an installer that even I (as someone who worries about cache clearances)can understand and have faith in.

    Ayesha

    February 14, 2011

  • Installed on My Mac and now have major loading issues. Every time I go to move the loading icon on my computer comes up. loading pages take forever and can’t move. Cleared all my caches and ran mac clean up..
    going back to old version

    Shawn

    February 14, 2011

  • I LOVE using Phoenix! Are we able to take pics with shadows yet? Would be great if we can!

    LisaMun Aronowicz

    February 15, 2011

  • I’m using a Mac, when I tried to install it the first time I got an error message. I had to redownload it to start at all. And what do I get? Something like 5-7 fps.
    Sorry to say it, but this sucks, big time.

    Lanita

    February 15, 2011

  • A lot of scripting doesn’t work with new Phoenix viewer.

    UnReleased

    February 15, 2011

  • And yet Linux users STILL have no Debian or Fedora packages or repos!! Are Linux users always going to be left behind when it comes to easy installation?? I for one don’t like having to mess around with manually extracting the binaries and setting file permissions and having to manually create launchers for programs (just like there are a lot of Windows users who don’t like programs that aren’t distributed without installers!). Are we EVER going to get the deb/rpm packages that we’ve been promised were ‘coming’??

    Aeronya Arai

    February 15, 2011

  • uh, that one Error IS gone, but HUD items still randomly detatch.

    TheGiant

    February 15, 2011

  • Is there no hope to see multiple tattoos on current Phoenix viewer?
    I would loove that….
    :P

    Laura18 Streeter

    February 15, 2011

  • Hope they have multi tattoo… *>*

    bumbumcat

    February 15, 2011

  • I like it for the most part, but music won’t play now for me. Works fine in 818, but not in 908 on any of my Linux systems (I don’t run Windows at all). I really want to use the new version, but as a SL DJ, not having music just doesn’t cut it.

    Antonius

    February 15, 2011

  • It’s a great viewer overall, but me and some friends been having problems with items reattatching themself on a new session that we took off on the previous session, it’s really starting to annoy us to the point we’re probally going to switch back to 818 till this is fixed or something..

    Mickie Mint

    February 15, 2011

  • Antonius, you need to copy the contents of the llplugins folder from version 373 to the llplugins folder in your 908 installation, this has been a known problem for many linux users with every version after 373 but apparently it’s too much to expect that it actually be fixed.

    Aeronya Arai

    February 15, 2011

  • Can you guys please attach a full change log file or leave a link to the change log when you announce an update? That would be great as I use it on every update and it was hard to find on the website. Thanks!

    Jonas Enge

    February 15, 2011

  • The new viewer is really great, but I’ve got two problems now.

    In edit-mode the selection beam points inside my Avatar and not to the selected Item. I’ve tested it with two other Viewers (LL standard and Kirstenliee), with both of them the selection beam works correkt. I’ve also disabled the selection beam in Edit Menu and reenabled it, without effect. With 818 the selection beam worked correct.

    The next problem, sometime the viewer crashes when I’m uploading a picture / texture. This only happens on a average used SIM but never happend with version 818.

    I’m looking forward and hope that there will be a public test for the firestorm viewer :-)

    damona

    February 16, 2011

  • Windows version seems to ru ok – no major probs yet. Linux version still has problems with music & media on my LinuxMint system. Copied old LLplugins across – gstreamer seems to fix missing music but media still doesn’t play (but at least no error now)

    Clive Egginton

    February 16, 2011

  • @Aeronya Arai I had no problems with 818 and music using the plugins that came with it and the plugins didn’t change between 818 and 908 (they have the same md5sum) but running 908 gives no music while 818 works perfectly for me. I’ll try the 373 plugins, but something is definitely screwy with the plugins.

    Antonius

    February 17, 2011

  • wish they would say what the differences between SSE and SSE2 are… kinda hard to pick your download without any type of indication

    Brett

    February 17, 2011

  • Sorry not sure why but the viewer just freezes constantly on me….basically cant use it atm :( any ideas?

    jayenguk

    February 18, 2011

  • After studying the wiki and following directions, I managed to get 908 to install. This took about an hour. Ran great for the 15 minute window I had AVG disabled. Then, even though I have the Phoenix Viewer folder path excluded from scans, AVG simply deletes PhoenixViewer.exe & the viewer crashes.

    At this point, it isn’t worth wasting my time for another 3-4 hours to kludge a workaround. So long, Phoenix. It was fun, but it’s obviously time for me to move on…

    djeaux

    February 18, 2011

  • i downloaded very unstable version of phoenix was kind of shocked textures and crash issues crashed more on the 908 then i did on the 818 went back to the 818 was happier to be there

    JuDo-StAtIc ===>

    February 19, 2011

  • SOmetimes when i log in i am wearing two pairs of shoes and i know for a fact that i did not have both pairs on when i logged off also things seem to detach from me then reattach at times.

    Pieces of Me

    February 19, 2011

  • I get the double problem with hair…Not a good look.I have two diff kinds of hair on…

    Silky Trilling

    February 19, 2011

  • another issue i get is the viewer just shuts off after 30 seconds of logging in – happens every time – old viewer would just close occasionally but atm this one is totally unusuable for me – still constant freezes as well.

    jayenguk

    February 19, 2011

  • I am suddenly getting performance alerts telling me that Phoenix Veiwer 908 is using 100% of at least 1 of my processors.

    Crixus Ravenheart

    February 19, 2011

  • Hi, THANK YOU for everything!!! Unfortunately 908 is a crash monster for me with Win7 / i7 / GTX580. I really can’t run it and either need to go to Imprudence / Ascent, or downgrade back to 818 (which ran near flawlessly for me)

    Is there an easy downgrade procedure?

    Thank You!!

    Vaneeesa

    February 19, 2011

  • So far, this release is just AWESOME! I noticed a huge difference in login time. I have a monstrously big inventory and it used to take several minutes to get through the inventory view, but now it’s like BAM! Got that? BAM! One more time? BAM!!! Needless to say, I’m happy. :D

    KittyCorner

    February 20, 2011

  • This is really great, but I’m still waiting for the “add ” for the alpha & tattoos layers, it’s impossible to have a new avi nowadays without tattoo layers, one for the tattoos, one for the lipstick, one for the eye shadows, one for the hairbase at least! Hopefully, it will be available on next release….

    Lollipops Crystal

    February 20, 2011

  • Still haven’t been able to download it… Downloads start up and proceed at a blazing speed of 10 kbps, and I’m not going to wait like I did in the early days of dialup.

    Eli

    February 20, 2011

  • Hi. I’m noticing high cpu usage on Mac OS X. In the 112% range according to the top command (quad core i7). Build 818 only ever usually ran as high as 30 percent or so. Could you look into this further? Thanks!

    Stephanie

    February 20, 2011

  • Really, really, really would love to have the ability to wear multilayers of tattoos at the same time – hate having to go to a different viewer to model….

    Shadez Rhapsody

    February 20, 2011

  • 818 viewers was stable – 908 Viewer crashes constantly unmotivated – even not improve the time Rez

    PamelaVegas

    February 21, 2011

  • once again, cant believe they offer SSE and SSE2 with no information on which version of windows, or hardware profiles they’re made for. i have windows 7 home premium (64 bit), an AMD phenom 2 x4 at 3.4GHZ, a 1GB GeForce 9800GT, and 16GB system ram, there is NO reason the viewer should constantly lock my computer up the way it is, this rig was built for much more rigorous gaming, come ph phoenix crew get your shit together this is pathetic. i tried SSE2, constantly crashes on TP, and randomly crashes in myown fully cache’d skybox and shop, im trying SSE, if that doesnt work, i give up. i’ve always loved phoenix, but this is insane. oh and another thing i noticed… after instaling i had the new 40 group limit…. 2 days later it went back to the old 20 group limit… that doesnt even make sense lol.

    Brett

    February 22, 2011

  • yay for the latest release … um not … my issues pre this release seem to manifest right before this release was launched such as the screaming RLVa assertion error and the group 42 issue ..both of which seem to have resolved. great! but .. the wearing items/not wearing items is getting beyond exasperating .. I’m not officially wearing huds yet looking straight at them on the screen, or my collar, yet can it and it functions, can detach EVERYTHING to try and resolve only to relog back in wearing half a boot and two hairs .. Am bored not clearing caches, got fresh collar, and have uninstalled and installed etc etc. and no different. this is all as well as the abrupt crashes or taking for so long to load when tp somewhere to the extent I’ve forgotten why I went there … I am failing to see what the improvements are at all. as said some of the ‘resolved’ issues only showed their head just before this release, which makes me think that if there was a preliminary trial version of this release, like a test-run, it is this which caused those now ‘fixed’ issues. I am struggling to keep with Phoenix as for the past 2 weeks has been a living hell, and I’ve run out of what else can do to improve, such as graphics low, poofers off, all done ..

    HeavenScent

    February 22, 2011

  • hey Brett … there is a free lil download http://download.cnet.com/CPU-Z/3000-2086_4-10050423.html CPU-Z .. which does a quick system check and returns information about all sorts of things regarding your computer, including which you have SSE or SSE (1, 2, 3, etc) .. I am supposed to be able to run SSE2 version, and in previous phoenix launches have done, but this time no, so uninstalled, re-installed the SSE which is less graphics demanding (as far as I know) but still no joy .. I read you words only after posting my .. and I agree… it getting very difficult to stay with Phoenix right now. best wishes to you (inworld – Fiz Barzane)

    HeavenScent

    February 22, 2011

  • my motherboard is a gigabyte that came bundled with easytune software for OCing, its basicly CPU-Z on steroids lol, according to the software i have SSE,SSE2,SSE3,and SSE4 so thats not where the problems lay, i switched to SSE to see if it would help, now every time the viewer crashes, it shuts my computer down as well which is extremly frustrating, and before anyone asks, no i have not OCd my rig, havent had any need to, aside from phoenix viewer, and including the previous version of phoenix, this rig can run everything i throw at it on max settings and 1024 draw distance, my hardware is NOT the problem, and judging by the hundreds of other comments, im not the only one with issues of the same type…. also been seeing several people talking about AVG going nuts detecting viruses after installing phoenix…. im not getting any virus alerts but i did start getting tons of tracking cookie alerts after installing phoenix, im starting to wonder if thats what the others are reffering to.

    Brett

    February 23, 2011

  • No better than the last, I like the old style interface but constant crashes and inventory not loading make this viewer almost impossible to use except on rare occasions when all the planets align

    John

    February 23, 2011

  • Just a suggestion: Add a “logout” option along with quit. Some people have multiple accounts for various businesses. Currently, you have to fully quit Phoenix and reload it. It would be nice if you could just logout and then login with another account.

    Trinity

    February 25, 2011

  • Anyone else been having an issue where if you open a browser while phoenix is open the textures on your avatar go all wonky?

    Shy

    February 26, 2011

  • Thank you all for the great viewer,I love it! Count me as another one who would very much love a multilayer tattoo function. Thanks

    Shimmer

    February 27, 2011

  • Yups, this latest update is surely a crash update. sometimes i get stuck when i am rezzing after just logging in. sometimes my little avie is just standing at home, low dd and bammmm a crash.

    bdtje.h

    March 1, 2011

  • After a week of freezing, slowness, crashing, system hogging and general crapness, I have reverted back to 818 – which is so stable you could use it as the point at which you lift the earth with a very long lever. No problems so far!

    Jinny

    March 1, 2011

  • I sent an email to you January 13th, 2011, about the current outfit folder. No response. Now again having problems with crashing constantly today and yesterday. Can I get a response this time? I’m not happy using phoenix viewer at all but seeing I have no choice cause other viewers I tried are much worse.

    Nerxual Oh

    March 3, 2011

  • Nevermind. You guys obviously do not care so that is fine. I’m forced to try viewer 2.5, the Linden’s viewer. And since they get paid for it, they would most likely help people who need it. Goodbye awful phoenix viewer.

    Nerxual Oh

    March 3, 2011

  • i have been crashing throughout the day is there a reason why its doing this?

    daniel

    March 4, 2011

  • OMG! I have never crashed this often before! What’s going on? It’s not only me!! I might go back to 818…this is rediculous!

    xuxacarnell

    March 4, 2011

  • There are some interesting comments here, but one I do not see is that this viewer, and its predecessor, 818, both cause my computer to write to disc far more than any other. Not HTTP get Textures related, I tried turningi toff – no change. While the PC writes to disc, the viewer slows and jitters. I wonder why? I have spoken inworld with Ed Merryman, who didn’t know what the issues was, but other s in the support group have seen this happen. Now my PC is fast but old and single core, maybe that has some bearing? Why isn’t this post in the Jira? ‘cos the damn system won’t let me in!

    Ayesha

    March 5, 2011

  • Installs perfectly, click to run and…..

    oops, there it is again ‘shutting down’.
    Log in page doesn’t even load :/
    Big big failness

    Vampi

    March 6, 2011

  • Since yeasterday my phoenix viewer isn’t working. It just loads until “Initializing texture cache” then nothing happens :`/ please fix is fast

    naitsirhc

    March 7, 2011

  • I am having the same issue. Did you get this fixed and if so, what do I need to do. This is becoming irksome.

    Xerick Savagard

    March 18, 2012

  • I try running my .908 and I get an error message straight away saying that the application configuration is incorrect? I’m running Windows XP Pro 32bit

    EternalJupiter

    March 23, 2011

  • Big BIG Crashtastic viewer! Myself and dozens of my friends will be using phoenix, then all of a sudden with no warning, we are instantly staring at our desktop… Where did the viewer go? It CRASHED… AGAIN.

    But no information about it.

  • 1.5.2.908 constantly crashes on my Mac Book Snow Leopard which has 4GB of Ram. Sometimes it even crashes the Mac and I have to reboot. Was not well tested. I stopped sending those reports.

    I went back to 818 and works well.

    Ky Clopas

    April 15, 2011

  • I keep getting disconnected when using “Phoenix Viewer Release 1.5.2.908!”.

    angelo

    April 18, 2011

Leave a comment (NOTE: We cannot provide support or help in these blog comments. If you need or want help please contact our support team through the correct channels. See our support page for more information.)  

name*

email*

website

Submit comment