Your browser (Internet Explorer 6) is out of date. It has known security flaws and may not display all features of this and other websites. Learn how to update your browser.
X

Phoenix Viewer Public Beta 1.5.2.977

(Download links at the bottom of this blog post)

There are two reasons we are pushing a public beta out so soon after our 908 release.

1/ We’ve been spending a lot of effort and  time trying to determine the instability issues which were/are present in our 908 viewer update for some residents. We think we have narrowed down the causes but need to test it on a larger scale than our QA team can provide. With more users on this beta, we’ll have a better idea in a week or two if we have identified the stability issues. If you have stability or performance issues on 908, we would highly encourage you to try running this beta for a few weeks or longer.

2/ We wanted to get the Media Filter feature out to the public sooner rather than later. This Public beta has the Media filter and you can read the documentation here http://wiki.phoenixviewer.com/doku.php?id=media_filter. While the filter is still not yet 100% complete, it is fully functional for it’s purpose which is to give you the ability to control the connections the viewer makes to the Internet. This feature is ON by default.

NOTE: This build will clear your cache before logging in for the first time. This is to ensure you don’t have texture cache corruption issues.

Aside from the above, below is a short list of some of the other changes we’ve made since 908.

Change Log
Interface translation fixes
Media filter
Updated GPU table for video cards
Adjusted login screen for low resolution screens PHOE-717
ParcelWL, Apply new settings without delay on TP
Texture memory fixes
Improved Jira link parser for jira links in chat.
Show/hide tp offers in Prefs> Popups> “Show teleport offer popups”
Small Improvement to failed logins
Fixed right click > export inventory only displays for scripts and notecards.
Fix for ATI related stars in the sky
Fixed “Let scripts to control my play button” in Prefs> Audio & Video
Fixed PHOE-2581, Copy prim torture settings from sculpt map to regular boxed prim bugged

DOWNLOADS:
*If unsure if you can use SSE2, please use the SSE. 
Windows SSE: http://downloads.phoenixviewer.com/windows/Phoenix_Viewer-1.5.2.977_BETA.exe
Windows SSE2: http://downloads.phoenixviewer.com/windows/Phoenix_Viewer-1.5.2.977_BETA_SSE2.exe
Mac: http://downloads.phoenixviewer.com/Mac/Phoenix_Viewer_1.5.2.977_Intel_Beta.dmg
Linux: http://downloads.phoenixviewer.com/Linux/PhoenixViewer-i686-1.5.2.977.tar.bz2

  • as w/all 1. 0 viewers this is seemless.. perfect.. ty..

    votslav

    March 13, 2011

  • Looks like there is an Issue with Snapshots…. Water & Sky are rendering as black..

    RichD Tomsen

    March 13, 2011

  • hope its better than 907 which kills me when i upload pics or am zooming and selecting things!!

    Julie

    March 13, 2011

  • The beta update has made no difference for me. I TP places fine .. the instant I try to move “CRASH.”

    Cincia

    March 13, 2011

  • Hello! Please, how do I enable Phoenix to enter into multiple accounts at once? Thanks!

    Jairo Liandro Henckel

    March 14, 2011

  • Quick comment: Just started with .977…I notice that it downloads into a folder it calls .908.. that will confuse some folk who don’t start up with a desktop icon.
    Otherwise it seems stable and there is definitely an improvement in texture-memory handling, thoiugh I think texture fetch-and-rez is a bit slower. Otherwise nice work on the media filter, the controls are simple to use. Thanks.

    Ayesha

    March 14, 2011

  • when you are planning to implement multiattach for the layers like in 2.0 viewer? =(

    sorry.asia

    March 14, 2011

  • its shytttttttttttttttttt all phoenix and i am getting so tired of crashing all time and not being able to tp!!!!!!!!!!

    cindyvdbulck

    March 14, 2011

  • Ok. Here is the problem I’ve been having. I don’t crash too often, but when I do crash, or relog, or log off and next time i log on, i have problems. I’ll log in, everything will be a dark foggy blue, and nothing loads. I have to relog again. Sometimes if i relog 5 or so times i can finally get in correctly, however most times i have to clear my cache each login, then when i finally do get inworld and functional, majority of my gestures fail to load. This has not changed with the beta from what I’ve seen so far.

    Stephy

    March 15, 2011

  • For some reason I’m getting about a fourth of the FPS in object heavy situations that I used to get. Insilico market I would be about 30fps with 908, in the beta with same settings, 9 fps. Huge disparancy, I wonder if it’s the new way textures are being handled?

    I’ve also noticed this drop in open sims where I used to see 40+fps looking out over it, dropping again to 9 or 13ish.

    Natascha

    March 15, 2011

  • Hi..

    I can’t use this Viewer. It won’t even start.

    I get an error:

    “This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.”

    Drandal

    March 16, 2011

  • @RichD…You most likely have shadows enabled.

    @ Julie…Your issues are most likey caused by having VBO enabled. This setting is forced off in 977 so hopefully you will see an improvement.

    @Jairo…This should be enabled by default, however its Advanced -> Debug settings -> AllowMultipleViewers -> Set to TRUE.

    @Sorry…This wil most likely never be implemented in Phoenix. It is however in Firestorm.

    @ Stephy… Disable all your active gestures, sounds like the problem is there. Also see http://jira.phoenixviewer.com/browse/PHOE-2548

    @ Natascha…Try reticking enable VBO in Edit -> Prefs -> Graphics -> Hardware Options

    @ Drandal… Make sure you have latest service pack on for windows then download & instal http://downloads.phoenixviewer.com/windows/AppFix.exe & Phoenix should run fine.

    Anyone having problems should file a Support Ticket http://wiki.phoenixviewer.com/doku.php?id=file_a_jira or Join the Inworld Phoenix Viewer Support Group

    Kirstie

    March 16, 2011

  • ok since it wont be the multi layers will never happen in phoenix, was the link to firestorm.

    THASCEPTIC1

    March 17, 2011

  • I love the Phoenix viewer. I hope all the glitches will be smoothed out soon. Now that my video media is finally working with this version, the voice chat just randomly(it seems)grays out, while I’m talking, while I’m not talking, just on a whim, or when someone else logs into SL from another PC on my network. Please offer info on how to stop this from happening or look into that while your working on the next release. THANKS FOR YOUR HARD WORK!

    Freedom

    March 18, 2011

  • Ooo you finally fixed the stupid stars in the sky?

    Amethyst Neiro

    March 19, 2011

  • mama mia I don’t know what you did but it put new life into my old computer! I’m getting double the fps that I used to have! And yes I have a sucky ATI graphics card.. that worked fine with everything BUT SL. It doesn’t suck any more! Thank you! Thank you!

    Carol

    March 19, 2011

  • I’m right there with Carol. This Beta made me let out a HUGE sigh of relief. I’m rezzing fast and not locking up anymore, like I’ve been with anything post-373. Amazing! I love it.

    Battlesword

    March 19, 2011

  • ok i’ve switched from 908 to 977….. i love the idea of media filter but, despite of my 20 mb connection, i cant rez fast enough, all avatars are and stil grey quiet a long, even the textures need long time to show themselves…it is me? ususally i log-in lately with a macbook with a gc nvidia 512 and xp sp3 (mac os spends too much time to rez)….any hint??

    bananos

    March 21, 2011

  • i crash all the time no mater what down load i use

    spirit

    March 22, 2011

  • On an IMac and 977 makes huge difference for me. No more moving,loading issues.. Great work

    But.. Please note* does not work with RLV
    Iog on and it works but then it stops working and cannot find RLV.

    Disappointing for me so will have to wait..

    Rhiannon

    March 22, 2011

  • Textures are taking twice as long to load for me now

    Stephy

    March 22, 2011

  • 977 corrected the texture corruptioon issue for me so far although on last login I had skin corruption again but cleared with rebake. Not crashing on the TP anymore but will need more testing for that since it wasn’t constant. Faster rez on landing and LOD issues seem resolved so far. (Mac Quad – ATI 8800)

    Arioch

    March 23, 2011

  • I just tried the 977 and am sad to say I still have horrible lag and my images (especially) trees are still flickering.

    Kathleen

    March 23, 2011

  • Hoping Growl notifications for Mac work in the next release, everything else seems to work nicely though.

    Poly

    March 24, 2011

  • I find the beta 977 much more stable. Crashes are greatly reduced, but still happen on occasion. (Intel Core2 Duo, XP Pro, SSE2)

    Al Jolbey

    March 25, 2011

  • Arg was hoping Growl would work sometime soon..been waiting for that for what, two releases now? Please bring it back!!!

    nepenthe

    March 27, 2011

  • Ok, when I first got this everything worked great. I have been in game for 3 years. But more resent I crash every 10 to 15 minutes and I can be at my home. I am about to pull my hair out. I have called my cable company and its not my connection

    sugaramy99

    March 27, 2011

  • This is just a friendly note from your Phoenix Support Team to let you know that yes, we do read this .. and, no… it’s not the appropriate place to get assistance. Please go to the support pages and look for inworld groups or one of our SUPPORT team members to IM (see links in the upper right of the top of the individual post’s page, or along the top of the main page).

    Thank you,

    Pud

    March 28, 2011

  • When will Phoenix make it possible for you to select where “notices” & “action” boxes place. I breed horses and constantly have my action box covered by notices – to be able to adjust when these show on screen would be a great addition

    Niel

    March 28, 2011

  • Clothing doesnt seem to attach correctly on occasions. Even after clearing my cache twice and a character test nothing was loading…. Reverting to .908 until .977 is debugged. :]

    Rosaliz

    March 29, 2011

  • The new Beta works very well compared to the last one, atleast for me. But i got this problem that it eats more and more ram memory the longer it stays running. Now im using Windows 7 Ultimate 64 bit version with a quad core on 3,4 Ghz and my ram memorys are 8 gig total with 1400 Mhz. My system runs very smooth in all high end games out on the market and i dont get this kind of memory glitch in any program. The beta version im using is the EES 2 im going to try out the EES one to see if that is more stable.

    DJ DannyY.C

    March 29, 2011

  • huge drop in fps in 908 and only slightly better in 977 beta but gets worse and worse the longer i’m on. i have to log out and log back in for it to improve. my mac runs incredibly hot which it never did. i also have problems with uncompressed snapshots on ultra setting which i never had before. i suddenly get lines through the image

    Biggi

    March 31, 2011

  • The version of Firestorm I looked at looks a lot like sl’s viewer 2. If this is what you plan on putting out as a new viewer I hate to say this I won’t be using it. Sorry but I don’t like the look and and the way it acts. Please change it to being closer to phoenix

    Jon

    April 1, 2011

  • Hi, I can’t get the classified ad links to open in search, have tried redownloading but still no joy

    Mericat Ireland

    April 1, 2011

  • I downloaded the new Firestorm, loaded it up, and tried it. Looked at it, closed it, dumped it, and restarted Phoenix. If that is going to be the future of Phoenix, I am going to become a luddite.

    Socrates

    April 2, 2011

  • Having trouble rezzing some textures with 977 at least one inparticular, of course thats the one that covers the prim my skybox is on. I do seem to be crashing less, but still do on occasion

    Gary

    April 2, 2011

  • I’ve been trying out the .977 version the past few days, and I have noticed a big improvement in load time for textures, smooth movement at least 95% of the time, only occasional freeze ups, my fps has increased, and I’ve crashed only once, but that was after teleporting to a graphic intensive sim and someone else teleported in on my head. My poor laptop video card screamed and gave up. ;p My sister has been running .977 on her desktop, and hasn’t crashed but once, and SL usually hates one of her video cards. Good job so far on this build.

    aquakittie

    April 2, 2011

  • Phoenix always just randomly logs me out….no freezing or anything. Screen just disappears. This is a new problem for me and disappointing because I enjoy using Phoenix.

    Betty

    April 5, 2011

  • Love the Phoenix viewer its realy the best.
    So when Firestorm was anounced i was like yes a new version, downloaded it and used it.
    I was shocked to see that it looked like the worst viewer ever V2 deinstalled it wright away.

    Great work on the Phoenix viewer thank you so much for that.

    Firestorm very bad im sorry to say that.

    JustJack

    April 6, 2011

  • How to see the alts

    Seba Littlebird

    April 7, 2011

  • Hi
    When I try to update I get this error message:

    An error occurred while trying to replace existing file
    DeleteFile Fail;code 5.
    Access is denied

    carefree93

    April 7, 2011

  • I still can’t get phoenix to work on my desktop still saying side by side configuration incorrect and I’ve no idea how to correct it.

    Shea

    April 8, 2011

  • I’m having inventory issues. It’s not SL because I logged on other viewers and everything was fine.
    Actually, at some point Phoenix decides to reduce my inventory, with like 30k items missing. The only thing I can do is clearing cache manually and waiting for the fetching, but after 7-10 days the problem shows up again.
    Thank you very much for reading this.

    Winter Viper

    April 10, 2011

  • I’m still crashing without any errors. Just goes to my desktop with no issue what so ever. There’s rumor this is a memory leak.. Something to do with OpenJPEG.. But I’m not certain. Otherwise I love it. It is, as always, the best viewer I’ve used. Just.. the random crashes really hurt when I’m building or in the middle of something big.

    Yume

    April 13, 2011

  • My clothes don’t load correctly, I’ll be wearing half of the new outfit and half of the old outfit. I’m also pregnant and I found that my tummy rumbler menu is only half there and I get sick when I don’t eat the food. Other than those 2 things, it works good.

    Jen

    April 14, 2011

  • I use Linux and i found it was slower that 908 more clunky …Ill try it again it might just have been a bad day ;-))

    trina

    April 16, 2011

  • So far 977 is, if anything, even LESS stable than908 was. I am (Not responding) and then crashing about 3 times an hour. About 1 time in 2 I crash trying to TP. The lag and CPU usage in 977 seems MUCH worse than 908. There are so many thing I love about Phoenix, but, for me, its been almost unusable since the 908 release. Was fine up to then.

    Also, still have all sorts of problems with my inventory never download.

    Katya

    April 20, 2011

  • I think the people who are crashing all the time have lame computers I crash rarely with Phoenix long may it reign.

    djspooky

    April 21, 2011

  • Got tons of empty folders in my inventory…. Where has it gone? tried so many fresh re installs its getting ridiculous!

    JAy

    March 5, 2014

Leave a comment (NOTE: We cannot provide support or help in these blog comments. If you need or want help please contact our support team through the correct channels. See our support page for more information.)  

name*

email*

website

Submit comment