Your browser (Internet Explorer 6) is out of date. It has known security flaws and may not display all features of this and other websites. Learn how to update your browser.
X

New Release! 4.6.5.40833

translation services

Another release! Already? Yes! Already!

We know it’s only been about two months since we issued 4.6.1 to you but we’ve been very busy since then and have accumulated a few new features, a LOT of bug fixes and performance improvements worthy of an early update! This 4.6.5.40833 addresses a great many of the common complaints we heard about with the last release and we expect this to be a big improvement for our user community. Even Mac users get some love this time around! Please get the downloads from our DOWNLOADS PAGE.

 

Highlights! (Not all by us and in no particular order! Please see full change log for full credits and authors of all work)

  • Voice fixes including latest Vivox Voice update, hear voice volume equally from everyone and voice works with multiple viewer instances as well.
  • Merge to LL 3.7.3 Codebase
  • Updated OpenSSL to 1.0.1g due to Heartbleed exploit.
  • Improved frame rate and performance on the 64bit version.
  • New preferences for builders, scripters and animators like prevent avatar from turning when selecting objects, preview animations on own avatar, constrain rotations to multiples of x degrees, and more.
  • Added features and fixes for combat users like avatar mark options in radar, name tag color override from marks and fixed tracker markers.
  • Improved Movelock  including the ability to move while engaged, text notifications when enabled/disabled and more.
  • Mac operating system gets some love with bug, crash and performance fixes like copy/pasting no longer appends garbage at end, sticky keys fixed, fullscreen functionality, view transparent shortcut.
  • Fixed: Moobs male avatar chest rendering issues effecting attachments and all worn mesh types.
  • SO MUCH MORE!

For a full list please see our CHANGE LOG

 

Enjoy!

Jessica Lyon and the Firestorm Project Team!

  • […] Sunday May 11th, the Firestorm team released Firestorm 4.6.5.40833. Given this release comes just two months after the 4.6.1 release, it does not have a huge raft of […]

  • I really don’t like to make waves on this sort of thing, but versions keep sweeping past with fixes for minor issues no one’s ever even heard about and the glaringly-bad state of the height offset/hover system going unaddressed…when it’s been long since fixed in other viewers. The BDSM community in particular takes deals with this on a daily basis, where kneeling/lying poses end up floating off the ground of burrowing down into it, but sooner or later anyone who does anything other than stand upright all day runs into it. When can we expect to see Firestorm catch up with the fixes other viewers have implemented ages ago?

    I know you hate to hear ‘but this other viewer’ comments, but this is a biggie, an overall quality-of-life fix, not just a niche feature, and it’s one that Firestorm used to have before it gave it up as impossible following some of the server-side baking changes. Well, other viewers have demonstrated it’s not impossible. So…where is Firestorm?

    Felina Kitty

    May 12, 2014

  • Do you mean this fix? http://realrestraint.blogspot.co.uk/2013/08/restrainedlove-viewer-2853-with-z.html?zx=d41c498ca82b3a69 referenced in http://jira.phoenixviewer.com/browse/FIRE-9566 ?

    This only works if your shape is modify.
    The devs also did not like the way this fix was implemented. Hopefully one of them can explain why – I’m afraid I forgot the details of why it was decided not to add this fix to Firestorm, other then “It’s a nasty hack”.

    Please comment and vote on http://jira.phoenixviewer.com/browse/FIRE-9566

    Whirly Fizzle

    May 12, 2014

  • Hi Felina!

    This feature was not adopted because the team regarded modifying a user asset by scripting calls as potentially dangerous and overall very ugly practice. It’s not a fix, it’s a bad workaround with the potential to destroy your shape if the asset doesn’t get saved back correctly, or a malicious RLV script goes nuts and changes your hover 10 times a second.

    Zi Ree

    May 12, 2014

  • Yes. It’s an ugly workaround. But that is infinitely superior to the present state of affairs of no workaround at all. Presently, players are forced into an even uglier workaround, that being just saving a half-dozen different shapes of different hover values to manually juggle between in the hopes of finding a good pre-made match. As for the risk of letting outside elements corrupt a modifiable shape…who the heck uses a modifiable shape without a backup copy SOMEWHERE?

    Is the current workaround used in other browsers perfect? No. Should Linden una** the bench and actually fix what they broke? Definitely. Should TPVs implement a workaround until there’s an actual fix? …why is this even a debate?

    Felina Kitty

    May 13, 2014

  • There is no debate. We are not implementing a potentially dangerous workaround.

    Zi Ree

    May 14, 2014

  • weren’t you the one complaining that FS doesn’t have frequent enough releases the last time?

    Can’t please some people…

    Iala

    May 12, 2014

  • “and the glaringly-bad state of the height offset/hover system going unaddressed”
    ————–
    That one’s on LLs. Its a bug in the official viewer that everybody else is also stuck with I guess. Any fix a TPV makes is going to have limited impact at best.

    —————————
    “weren’t you the one complaining that FS doesn’t have frequent enough releases the last time?”
    —————————
    No that’s usually me. Its good to them them being a little faster this time – though they seem to have missed the cut with the ‘project interesting’ stuff. Which means they’re still a major release behind. Hopefully they will update near about the same time LLs merges ‘interesting’ with the flickr/twitter integration of ‘Sl Share’…

    Pussycat Catnap

    May 12, 2014

  • I just installed the new version. I did all the necessary requirements, and I’m getting an error every time i double click on firestorm to load. It gives me a crash error log. I never had a problem with this before. I try and send a report but, it won’t connect to your server. I don’t know what to do.

    Newport Moonwall

    May 15, 2014

  • Great job firestorm team, the performance of the 64 Bit version is stunning. The one thing that makes me a bit sad about this update is that it indicates you won’t include “project interesting” anytime soon in an official release. Given the fact how much this has improved the mesh rezzing issue for buildings I was itching to see this in Firestorm so we can finnally drop our mesh builds that only half of the people see half of time if we’d drop it now. I am sure it is something you guys are looking in to.
    Keep up the great work 🙂

    Steph Catseye

    May 12, 2014

  • The interest list changes in viewer-interesting will get picked up, probably in the next major release. This release was all about bug fixes and such, and those changes were too significant for that.

    Tonya Souther

    May 12, 2014

  • Project Interesting only became publicly released while we were nearing the end of our QA period of this build. Interesting will take a considerable amount of work to merge into the viewer as it touches and involves a LOT of code. We will try to get it out in our next release.

    Jessica Lyon

    May 12, 2014

  • Good Job!!! Seems to be the best viewer you ever have made.
    As far i can see there are two new options in preferences > caches: clear inventory cache and clear browser cache? Is it something i need to do? Can i read about it in the wiki?
    Thanks Again!
    Freja

    Freja String

    May 12, 2014

  • Freja If you performed a clean reinstall exactly as the wiki outlines, you will not need to touch your cache. The only time we recommend anyone clearing their cache is for specific texture corruption issues and the rare inventory issue. Since you just upgraded to the newest version, if you followed the wiki on clean reinstall, then you began with a clear cache and another one won’t be needed.

    Gweneth Lange

    May 12, 2014

  • you should not clear any caches, usually. only if you’re completely borked.

    sinead mcmillan

    May 12, 2014

  • lol,
    i clean mine often, and it keeps my viewer purring like a kitten, plus a few debug tweaks too of course. 🙂

    hotdivaqueents

    May 13, 2014

  • Guys, thank you for all the improvements and fixes.
    But I’m in rage.
    Your installer has deleted the existing installation in my portable apps folder and created new one in standard program files folder. That’s outrageous. I want to choose where to keep my apps and I certainly don’t want Firestorm to do anything stealthily behind my back.

    Mystery Keeper

    May 12, 2014

  • Is this the 64-bit installer? There is an “Options” button when you run the installer where you can choose the install path.

    Whirly Fizzle

    May 12, 2014

  • I didn’t have that button during my installation. It only asked me if I agree with user agreement and then did everything by itself.

    Mystery Keeper

    May 13, 2014

  • I can assure you.. it is there. http://i.imgur.com/4oLC02b.jpg . Once you click it you see http://i.imgur.com/UYXoLYp.jpg

    Jessica Lyon

    May 13, 2014

  • Can not confirm it now since I can not install the previous version anymore. Anyway, since installer knows where previous installation is, it would make sense to install to the same folder by default.

    Mystery Keeper

    May 14, 2014

  • Should this be a clean install or can we just run the installer?

    Drake1 Nightfire

    May 12, 2014

  • “ADDED Added an option to prevent avatar from turning to selected object when editing”

    Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you! Thank you!

    In case you missed it, Thank you!

    Rich Reynaud

    May 12, 2014

  • another ‘thank you’ from me, too, for that.

    Taeem

    May 15, 2014

  • i’m getting an error when i try to log in…

    “We are sorry, but Firestorm has crashed and needs to be closed. If you see this issue happening repeatedly, please contact our support team and submit the following message:
    ERROR: newview/llvotree.cpp(115) : LLVOTree::initClass: failed to parse tree file.”

    i filed a jira about it…
    http://jira.phoenixviewer.com/browse/FIRE-13700
    any suggestions? anything i should do in the mean time?

    eksynn

    May 12, 2014

  • This error happens when the install is messed up in some way.
    Please do a clean install and your problem will be fixed.
    Instructions for how to do this are here: http://wiki.phoenixviewer.com/fs_clean_reinstall

    Whirly Fizzle

    May 17, 2014

  • In the first impression, a fast viewer in the 64 bit version.
    Unfortunately, still with far too few texture memory, but we are in constant expectation, that we will also arrive with this sometime the 21st century.

    To judge all others, it is not yet time. However, at least no bad surprises after installation. and that are good news. Thanks to the development team for their dedicated work.

    Sincerely!

    Findbhair
    )O(

    H.I.H. Gr. Princess Findbhair Nikolaevna

    May 12, 2014

  • […] Quelle: New Release! 4.6.5.40833 […]

  • Until i install it i cant say any but congrats.

    zzpearlbottom

    May 12, 2014

  • that list of “known issues” is a bit tough, isn’t it? i am hesitating to clean install this version. /specs.: win7, 64, lots of ram etc.

    sinead mcmillan

    May 12, 2014

  • […] to Firestorm 4.6.5 codebase. Lots of good stuff […]

  • I hate to sound like a train wreak but there is an issue. I can easily take care of the pink attachments problem….but as with everything new in Firestorm…..another arises from the ashes like a new firebird.
    I think if I can get this issue resolved I will be happy with the new version. My skin is distorted a bit, then I hit appearance and it’s gone till I get out of appearance mode. Any Ideas?

    Taima Fang

    May 12, 2014

  • I had this problem too, but clearing the cache appears to have fixed it, thankfully.

    Icra Nosferatu

    December 21, 2014

  • How do I know which version I should install, 32 or 64? Any help or tips will be much appreciated.

    Beryl Landar

    May 12, 2014

  • Well I know I cannot download the 64 version lol…I just tried 🙂 need newer version of Windows. Now to try the 32.

    Beryl Landar

    May 12, 2014

  • Generally, the version of FS you install should be the same rating as your O.S. Example: Windows 7- 32 bit needs the Firestorm 32 bit version. Windows 7- 64 bit will run the Firestorm 64 bit or the 32 bit. Which version you choose depends largely on how well the version works. Your Graphics card can also have an effect on this too. Basically, try and choose. That’s what I do.

    Damien Avedon

    May 13, 2014

  • […] it was released this weekend while I was off doing Mother’s Day stuff. See the announcement: Firestorm Viewer Release 4.6.5-40833. Also, Inra has a nice review of this release up here: Firestorm 4.6.5: steady as she […]

  • I’m only going to say that this 64 bit is a HUGE improvement on 4.6.1, but I do wish the installer would let me chose where to instal rather than just going and putting it on the main drive. I used to get a choice, now I have to move the folder and make a new shortcut for my system. It is a minor whinge since on the whole this is a graet piece of code! Congratualtions once again to the devs.

    Ayesha Askham

    May 12, 2014

  • There is an “Options” button when you launch the installer that lets you choose the install path.

    Whirly Fizzle

    May 12, 2014

  • D’oh…I did wonder…ah well, I’ll know for the next install!

    Ayesha Askham

    May 13, 2014

  • Getting ‘A certificate could not be built to a trusted root authority’ error when trying to install the Win64 version.
    In the logfile the main problem seems to be ‘[0EA8:0D10][2014-05-13T01:15:52]e000: Error 0x800b010a: Failed authenticode verification of payload: C:\ProgramData\Package Cache\.unverified\Setup’
    Tried this twice now with a fresh download each time. Same error.

    This is NOT a clean install. On the other hand I am hugely reluctant to zap my existing installation until I am sure this one will install.

    Gil Druart

    May 12, 2014

  • You need to update your root certificates http://support.microsoft.com/kb/931125

    Whirly Fizzle

    May 12, 2014

  • You will need to update your operating system root certificates. You get do that from here.. http://support.microsoft.com/kb/931125

    Jessica Lyon

    May 13, 2014

  • NOTE: We cannot provide support or help in these blog comments. If you need or want help please contact our support team through the correct channels. See our support page for more information.

    We (meaning support staff) sometimes visit the blog and post comments. Sometimes not. Your best bet for support related questions is inworld via our Firestorm Viewer support group or through the jira.

    Gweneth Lange

    May 12, 2014

  • X64 installer refused to instal (jira filed) because
    – another Microsoft C++ more recent redistributable version was found
    – a folder \users\public\Desktop can’t be accessed (insufficient privileges, even when logged as an administrator and executing the installer as an administrator). Actually I can’t access this folder at all myself, even after trying to take ownership of it. I don’t even have the authorization to see its authorizations…)

    Beatrice Songbird

    May 13, 2014

  • You need to goto your access page and become an Administrator rather than a user. MS is really retarded here, since this problem has been going on since 3.1. You HAVE to enter as an Administrator even if you are the only user of the computer. Once you set yourself up as an Administrator, stay there. Just don’t fiddle with any of the .cmd functions unless you have instructions on what to do. Administrators can destroy a Windows system with bad commands while users can’t. I guess its MS’s Suspenders and a Belt version of OS Security.

    Damien Avedon

    May 13, 2014

  • How is Microsoft retarded? really?
    if I want my account as an admin and I want someone else to be a user, do you think I want them to install any crap they want in my computer? that’s why users and administrators exist in first place.

    but you should know, you can ask admin permission and put the admin password and install it without go in a admin account.

    people should be admin of their computers. never users. if it’s their computer, it should be that way, if not, it means it’s not their computer or someone set it up wrong.

    Emi

    May 19, 2014

  • Installed 64b version in less then 5 min,
    Clean install but roaming (didnt sant to waiat a day to sett it to my preferences, pure v3 style interface and some debug settings, like Mona’s camera fov, maxmeshreq to 64 and rendvolume lod factor to 15 (dont give me a lecture in how to not do that!).
    Cant find a simple fps counter that would show just numbers, so i had to use the led.
    Cant find a way of removing the, sorry to type as this:
    Message, that we are entering on a region running a diff simulator version.
    For some that travels every day on a few hundreds of mainland regions, to see every time we cross a sim, that thing, is simply disturbing at the best.
    Of course i forgot to tell that i run all at ultra, lifelike settings, shadows up to 4x and 1024 draw distance, without a single fps issue, finnaly some viewer that justifies my Gtx780ti investment.
    Win 7 64b, 12 giga ram ddr3 and intel 7 cpu my other main requirements.
    Hoooo and bridge detached always (Sorry but i do refuse to use that thing until some shows me why we do need it on open sim or even on Sl), ao feature on on Open sim, off on Sl as i use sub ao there).
    So in the end, no problems to install, launch and start enjoying OSgrid.
    On Sl, besides those really annoying notices, for some that moves around so many sims and that i do hope one wil tell me how to deactivate asap, worked as expected.
    If Firestorm team decides to do a lite version, just with v3 interface and just the features one really needs for sure it will be my viewer on sl as it is on open sim.
    As at now, it is a pretty good improvement but not my Sl viewer.

    zzpearlbottom

    May 13, 2014

  • While I like the promo for the new system, I’ll wait for the release that has the new loading system in it. What I have works fine for me as it is. Once I can drop the “Load Dammit” gesture, I’ll go with a new version of Firestorm. What I have now (64 bit) is wonderful enough.

    Damien Avedon

    May 13, 2014

  • Well newest version says voice has been fixed and I’ve had it an entire day…and yes I clean installed it and voice has randomly cut off on me several times. To me this is not fixed.

    Kessryll Stormcrow

    May 13, 2014

  • HEARTBLEED not “Heardbleed”.

    Ailasa

    May 13, 2014

  • Fixed 😀

    Whirly Fizzle

    May 17, 2014

  • Fantastic viewer, the best FS yet.
    I greatly disliked 4.6.1, but eventually found a way to deal with it. This new 4.6.5 is an absolute dream, in comparison.
    Running the 64-bit version and it’s pretty much flawless. Every single issue I had in the previous version seems to have been cleaned up. Combined with the new PC I recently built, it’s once again a pleasure to wander about in second life.
    Well done, Firestorm team. Your work is greatly appreciated 🙂

    Cody

    May 14, 2014

  • Odd thing. I’ve downloaded the .exe file for Phoenix-FirestormOS-Release-4-6-5-40833_Setup on two separate computers, both running WindowsXP, and the file won’t run on either one. Is there a generic issue of which I ought to be aware, or must I file a JIRA?

    angelpatty

    May 14, 2014

  • One resident said they got the crash error:

    “We are sorry, but Firestorm has crashed and needs to be closed. If you see this issue happening repeatedly, please contact our support team and submit the following message:
    ERROR: newview/llvotree.cpp(115) : LLVOTree::initClass: failed to parse tree file.”

    I am getting the same thing, but nobody answered their question. Does anybody know what this means?

    Tiffany

    May 14, 2014

  • Right here with Tiffany on this one. Still clueless.

    Sunshine

    May 14, 2014

  • This error happens when the install is messed up in some way.
    Please do a clean install and your problem will be fixed.
    Instructions for how to do this are here: http://wiki.phoenixviewer.com/fs_clean_reinstall

    Whirly Fizzle

    May 17, 2014

  • I’ve filed a JIRA about Phoenix-FirestormOS-Release-4-6-5-40833_Setup (1).exe not running on either of my computers.
    It still won’t run on them.

    angelpatty

    May 14, 2014

  • Well, in general this version seems to use a smaller memory footprint while running. I can’t speak for any bug fixes because I haven’t noticed any changes on the features I use. Two things. It seems to lose settings somewhat regularly and I get that ‘textures discarded due to insufficient memory’ error more frequently than before. It’s not enough to make be downgrade to the earlier version, but I hope it’s not a trend.

    I will put my vote in to make getting the ‘Interesting’ code into the next release the absolute top priority over adding any new features. It may not matter so much for those with high end systems, but it most certainly does on lower end ones. The performance increase I get as far as my camera view rendering and my basic FPS with the current LL viewer using similar settings to what I use with Firestorm is fairly significant. For interaction within a single sim, Firestorm is adequate. When I want to hop in a vehicle and cross sims one after the other? LL’s viewer beats Firestorm hands down on my system. SO I maintain both viewers and use the one that will work best for what I’m going to do at the time.

    Crim Mip

    May 14, 2014

  • I don’t know if anyone else is experiencing this but it appears as if all the particles systems contain firestorm fire effects on them. This is quite annoying and ruining many effects around the world. This is an image of a brass ejection effect that used to work but now is broken.
    http://i.gyazo.com/98f1e928cd2a98d4b6a29d2e8d2e4280.gif

    To-mos

    May 15, 2014

  • Yes, this is a known bug on all viewers that support ribbon particles.
    Please see:
    http://jira.phoenixviewer.com/browse/FIRE-11744 and
    http://jira.phoenixviewer.com/browse/FIRE-11745

    Whirly Fizzle

    May 17, 2014

  • I just bought a new souped up laptop, and it is fitting that the day the laptop arrived, you release the newest version of Firestorm. I love it.

    North Reisende

    May 15, 2014

  • Running latest viewer on iMac (yes, did a clean install). OS – 10.6.8. Processor – 3.06 Ghz intel core 2 duo , 4gb 1057 MHz DDR3 memory.

    I do like the changes you all have made (including the teleport offer/request in IM). However…..

    My problem is viewing mesh. Previously, just fitted/liquid mesh looked like flat colored prims coming out of an avatar, but in latest version, even the previous kind (rigged? Unrigged?) of mesh is looking like this. Is there a setting change that I can make so that all mesh looks correct in my viewer.

    Connie Beck

    May 15, 2014

  • The only real fix for your problem is updating to Mavericks.
    Even if you update and you have an AMD card, you will still see some rigged meshes (fitted or not) with vertices stretching out to <0,0,0> on the region.
    If you disable Hardware Skinning under Preferences -> Graphics -> General, this should workaround the bug.
    Please see http://jira.phoenixviewer.com/browse/FIRE-13071 and https://jira.secondlife.com/browse/BUG-5139 for details on this bug.

    Whirly Fizzle

    May 17, 2014

  • I still suffer from stretched meshes, with clean install, and the following specs: Processor 3.1 GHz Intel Core i7, Memory 16 GB 1600 MHz DDR3, Graphics NVIDIA GeForce GT 650M 512 MB, Software OS X 10.9.3 (13D65). Even Ebbe Linden’s avatar looked crappy under these circumstances: http://arduenn.com/img/ebbe.jpg

    Arduenn Schwartzman

    May 31, 2014

  • You shouldn’t be seeing this bug with Nvidia graphics. You are using the 4.6.5 release and not a previous version? Only 4.6.5 is fitted mesh compatible.

    Whirly Fizzle

    May 31, 2014

  • And I’m back to 4.4.2 again (Mac/Mavericks), because in 4.6.5,

    1. Objects and mesh load 5 times slower
    2. Text editing responsiveness slows down with lower frame rates
    3. Alt-clicking sends my camera to weird places
    4. Lower fps at complicated meshes
    5. Milky Windlight waters
    6. Smaller script font

    Each version after 4.4.2 had (some of them show-stopper) quirks for me, similar to the above. I’m so done now with writing Jira after Jira. Just please don’t block 4.4.2 until something tolerable has been released for me.

    Arduenn Schwartzman

    June 2, 2014

  • Well, you will be seeing all fitted mesh as stretched on 4.4.2 – afraid we cant do anything to help that, 4.4.2 isn’t fitted mesh compatible.
    1. Are you using webroot antivirus software? This is known to cause poor performance and very slow rezzing on newer viewer versions because it scans the viewer cache in real time.
    4.6.5 also contains LL’s new HTTP protocol, which may be disaggreeing with your setup for some reason. We would need to see logs to have any idea what’s wrong here so the only way to go here is a support JIRA issue please.

    2. This is a known Cocoa bug on Mac – see http://jira.phoenixviewer.com/browse/FIRE-12172. 4.4.2 was the last version of Firestorm not to suffer from this bug. There is however a test build available with a fix for this bug. Leave a comment on http://jira.phoenixviewer.com/browse/FIRE-12172 if you would like to be sent the test build.

    3. Also a known Cocoa bug on Mac on all versions after 4.4.2 – see http://jira.phoenixviewer.com/browse/FIRE-12241
    No fix available yet but LL is working on this one.

    4. Materials and fitted mesh happened. Nothing comes without a cost I’m afraid.

    5. This is also a known issue since the Materials code was added to the viewer – see http://jira.phoenixviewer.com/browse/FIRE-11360
    Its a renderpipeline issue so the fix will have to come from LL. This one will probably not be fixed however.

    6. Others have complained about this too – see http://jira.phoenixviewer.com/browse/FIRE-4386
    You can change this yourself – see the instructiuons in the comment on that issue.

    Whirly Fizzle

    June 2, 2014

  • There needs to be a BIG red label no the download page, release summary, announcements making clear that XP is not allowed with this version. I spent 15 min downloading. It will also remind the folks how many of us are still using XP since I am sure you will receive a fair amount of feedback asking for XP support.

    With an eye the resource allocation argument: there might be XP users than there are Linux users.

    http://en.wikipedia.org/wiki/Usage_share_of_operating_systems

    not given

    May 15, 2014

  • There needs to be a BIG red label no the download page, release summary, announcements making clear that XP is not allowed with this version. I spent 15 min downloading. It will also remind the folks how many of us are still using XP since I am sure you will receive a fair amount of feedback asking for XP support.

    With an eye the resource allocation argument: there might be XP users than there are Linux users.

    http://en.wikipedia.org/wiki/Usage_share_of_operating_systems

    XPUser

    May 15, 2014

  • Sorry, what exactly are you smoking and can I have some please?

    Oh! You must be using XP Service Pack 2!

    Want to stick with XP? Update to SP 3.

    Dark Wolf

    May 15, 2014

  • The viewer will still install on Windows XP, however you must have the latest service pack installed – that’s service pack 3 for XP 32 bit or service pack 2 for XP 64bit.
    Once your Windows XP is up to date, the viewer will install.

    Whirly Fizzle

    May 17, 2014

  • Gosh XPuser, You may want to get a little more involved with your pc if you intend to keep running an OS that the OS maker no longer supports. Do you really imagine the world of software is going to devote a lot of resources to making sure their programs work on an OS that was released nearly 13 years ago?. I have XP computers but I also know full well that keeping them running is increasingly falling to me and the decisions I make. I would seriously recommend that you start socking away your shekels in anticipation of the likely necessity of getting up to date or you may find your self painted into a very small corner.

    Georgie Tunsgten

    May 19, 2014

  • I notice that behavior when the scenario is still uploading.
    Mesh items sometimes seem to be the latest to render correctly.
    But that problem is not exclusive to Firestorm.

    zzpearlbottom

    May 15, 2014

  • New update has SERIOUS issues with Graphics. Sadly can not reinstall previous. Anyone out there who reads this…DO NOT UPDATE..not before your sure the bugs are fixed.

    Lady Denise

    May 15, 2014

  • Lady, ” SERIOUS issues with Graphics” does not tell us much. It would be helpful if you can file a JIRA issue giving your system information and snapshots showing whats going wrong with your graphics.
    http://wiki.phoenixviewer.com/file_a_jira

    You can download the older versions of Firestorm here: http://wiki.phoenixviewer.com/fs_older_downloads

    Whirly Fizzle

    May 17, 2014

  • Where is the Havok version for SL grid only?

    E

    May 19, 2014

  • All the downloads are listed here: http://wiki.phoenixviewer.com/downloads

    Whirly Fizzle

    May 26, 2014

  • Hey guys!

    I love the update!

    I’ve only one complaint =/ In the old viewer, which was v4.4. each time i opened a folder in my inventory, i could close it with just hitting “enter” key of my keyboard of my laptop. In this new upgrade, I’m not able to close the folders with the ENTER key option. 🙁 I can still open the folders with the enter key, but not close it. Is there an option to enable this?? 🙁 I truly hope so, because i get finger cramps when it comes to cleaning my inventory while i am being forced to manually close my folders. Sorry, i do not like complaining, but this is one and only thing that bothered me greatly. 🙁

    FioraRae Resident

    May 22, 2014

  • Whirly Fizzle

    May 26, 2014

  • Estou com um problema,tem pessoas no jogo que olham em tiras de mesh o que será isso! E as enxergam meu avatar com luzes saindo dele,ou em tira de mesh,sao algumas pessoas,algumas me enxergam normal.
    Preciso da ajuda de voces para corrigir esse erro!

    Ola

    May 23, 2014

  • Hola Ola,

    Parece que usted está viendo este error: http://jira.phoenixviewer.com/browse/FIRE-13071
    [BUG-5139] [MANT-3739] ATI / AMD Ciertos tramos de malla amañado a 0,0,0 (sólo deshabilitar solución Skinning Hardware)

    Whirly Fizzle

    May 26, 2014

  • I’m getting this error can anyone tell me how to fix it I have tried uninstalling and installing again Error: newview/llvotree.cpp(115) : LLVOTree::initClass: Failed to parse tree file.

    Alasia InglePodless

    May 24, 2014

  • This error happens when the install is messed up in some way.
    Please do a clean install and your problem will be fixed.
    Instructions for how to do this are here: http://wiki.phoenixviewer.com/fs_clean_reinstall

    Whirly Fizzle

    May 26, 2014

  • The installer won’t launch on Windows Vista. I can’t update.

    ~ Gee

    May 25, 2014

  • The installer should work on Windows Vista.
    If you are having problems installing, please file a support ticket on the JIRA and support can help you.
    http://wiki.phoenixviewer.com/file_a_jira

    Whirly Fizzle

    May 26, 2014

  • I also cannot get the new Firestorm to install on Windows Vista. I click on the installer, get the little green wheel for a second or two, and then … nothing happens. I did a clean install so now I have exactly 0 usable versions of Firestorm. Very frustrating.

    Pat Powers

    June 12, 2014

  • The older downloads can always be found here: http://wiki.phoenixviewer.com/fs_older_downloads

    Pat we can have no idea why the installer is failing for you without more information. Please file a JIRA issue and support will help you: http://wiki.phoenixviewer.com/file_a_jira

    Whirly Fizzle

    June 12, 2014

  • After installing the new viewer, then uninstalling, then reinstalling, then doing the full clean instal process twice I still cant get on SL!
    It is always the same thing I am able to log on, my character comes out of the cloud into the avi. Then RLV fails to connect, and I crash. I am almost about to give up. This new update is so horrible!!! Please fix so that I can move around, teliport, heck even talking to other people would be an improvement over what I am able to do after this update…

    Soulcalaber Gearhead

    May 26, 2014

  • We need at least your full system information and your crash logs to have any idea what is wrong here.
    Please file a support ticket on the JIRA giving your system information and logs.
    This page tells you how to do this: http://wiki.phoenixviewer.com/file_a_jira

    Whirly Fizzle

    May 26, 2014

  • i have a issue with firestorm launcher it keeps on crashing each time i log in with this new one? 😮 anyone have same issue or know what the issue might be?

    Nakatina

    June 4, 2014

  • WE would need to see your logs to have any idea of why you are crashing.
    Taking a guess – if you are getting the error “error: newview/llvitree.cpp(115) : LLVOTree::initClass: Failed to parse tree file” then you need to do a *clean* install – instructions for how to do that are here: http://wiki.phoenixviewer.com/fs_clean_reinstall

    If that does not help the please file a JIRA issue and be sure to add your log files.
    This page tells you how to do this: http://wiki.phoenixviewer.com/file_a_jira

    Whirly Fizzle

    June 4, 2014

  • As someone who has used Firestorm since it first came out I wish you guys would sort the basics out.

    I know my way round the viewer because I have been using it so long and have tried to champion you all along.

    Irritation no. one is the fact that attached items rarely rez on TP – I have to spend 5 mins individually “editing” my attachments to get them to show at all.

    Main bugbear is I cannot visit a busy SIM without crashing because of texture discards due to out of memory errors. With each release of FS this problem gets worse. SIMS I used to hang out in using FS are now impossible to visit. My system is up to date and this is not a Windows problem. My Linux box crashes even quicker on the same SIMS. There is no excuse for memory leaks – that is just bad programing on someone’s part.

    Firestorm has gone from being the best SL viewer to being almost unusable in the time I have been using it. I have now resorted to the official SL viewer with all its horrible HCI issues – but at least I can stay online with it

    Please fix what used to be a great product but is rapidly becoming a pile of unusable garbage.

    DV.

    DV

    June 8, 2014

  • We cant really help you unless we get more information.
    If you file a JIRA issue and be sure to include a paste of all your system information and attach a zip of your logs folder after a crash, we can take a look.
    This page tells you what to do: http://wiki.phoenixviewer.com/file_a_jira

    Whirly Fizzle

    June 8, 2014

  • I have a Toshiba laptop L775, core i3, Windows 7, 64 bit. I was running FS version 4.4.* It worked fine, but I was encountering some issues with the new mesh avatars, so I upgraded to 4.6.5. I have tried 6 different times now to log in on every new version available (32, 32&os, and 64) The install takes just fine, but when I launch FS, it freezes on “initializing VFS”. I did a clean install every time. In fact, I have gone through my computer this last time and deleted any and every file associated with Firestorm before the install. It is as though I have installed Firestorm for the very first time. It still freezes on “initializing VFS”. I can’t seem to find any info on addressing this issue with the newest version on the web. Please, can anyone help me??? I am at my wits end!!!

    J

    June 13, 2014

  • First thing to try is manual cache clean – see http://wiki.phoenixviewer.com/cache

    If that does not help, please download and install the official LL viewer from https://secondlife.com/support/downloads/ and see if this also freezes at “initialising VFS”.
    If it does its likey to be a graphics driver problem.
    Make sure you are on the latest driver for your card and if that does not help, please file a JIRA issue making sure to give a paste of all your system information (you can get this from the 4.4.2 version if it still works) and a zip of your crash logs.
    This page tells you what to do and what info to include: http://wiki.phoenixviewer.com/file_a_jira
    Please be sure to mention in your JIRA report if the official viewer also freezes, because this is one of the first things support will probably ask you to check.

    Whirly Fizzle

    June 13, 2014

  • I keep having issues logging in, i can’t count how many times I’ve cleaned out all my firestorm directories and files and reinstalled the update and “Something unexpected” still keeps happening no matter what i do. Please tell me how i can fix this or who i need to talk to because it’s not just this viewer and i’d like to avoid using the standard SL viewer any further.

    Mochalex

    July 9, 2014

  • Please see http://wiki.phoenixviewer.com/getting_help for how to get help.
    If you are unable to login, you can file a support ticket on our JIRA: http://wiki.phoenixviewer.com/file_a_jira

    Whirly Fizzle

    July 9, 2014

  • This is bullshit that the installer does not inform me about errors. And how can I know what is wrong?! Bullshit.

    Manoul

    October 12, 2014

  • zzpearlbottom

    July 14, 2014

  • What happened with windlights? They dont’ look like in the previous version, where they were more soft, now any windlight I use, with shadows or not my have is ugly. My windlights looks horrible in this version. How can i fix that?

    Anna

    August 10, 2014

  • What happened with the windlights? They don’t look like in the previous version, where they were more soft, now any windlight I use, with shadows or not my face is ugly. My windlights looks horrible in this version and I can’t take good pictures anymore. How can i fix that?

    Anna

    August 10, 2014