Your browser (Internet Explorer 6) is out of date. It has known security flaws and may not display all features of this and other websites. Learn how to update your browser.
X

1.5.2.818 Final Major Release!

It’s finally here! As promised.. a Christmas Release! Our final major release version 818. \o/

A few things to note…

We are no longer providing SSE and SSE2 in one installer for windows. We’ve gone back to providing two separate downloads for each because too many people were getting confused.

We will be using the SSE Standard binary in our quick download links because it works for everyone. For the SSE2, please go to our downloads page. When in doubt of which one to use… use SSE! It works for everyone, and while many systems can run SSE2, they don’t necessarily run it well. If you have a performance decrease on this version while on SSE2, use the SSE instead.

While this is our final ‘major’ release.. we will continue to have releases for Phoenix but they will mostly just be bug fixes and improvements.

Among many other changes we have added Display Name support in group, IM and local chats, radar, friendlists, partners etc, fixed a lot of RLV issues from 725, fixed voice issues on Linux and Windows, fixed the viewer lockups from 725, Parcel WindLight water settings, fixed the crash on “Initializing Multimedia” and “Failed to initialize application” errors some people were getting… etc etc etc, 

Full change log here:
http://wiki.phoenixviewer.com/doku.php?id=818_release_notes

Windows SSE: 
http://downloads.phoenixviewer.com/windows/Phoenix_Viewer-1.5.2.818_STANDARD.exe
Fixed ^

Windows SSE2:
http://downloads.phoenixviewer.com/windows/Phoenix_Viewer-1.5.2.818_SSE2.exe

Windows Failed to Initialize fix:
http://downloads.phoenixviewer.com/windows/Phoenix_Viewer-1.5.2.818_Fail2Init.exe

Mac:
http://downloads.phoenixviewer.com/Mac/Phoenix_Viewer_1.5.2.818_Intel.dmg

Linux:
http://downloads.phoenixviewer.com/Linux/PhoenixViewer-i686-1.5.2.818.tar.bz2

Special thanks to Jed Gregg, Crystal Glasswing and several other users for enduring dozens of trial and error builds in order to help us fix the long standing “Initializing Multimedia” and “Failed to initialize application” errors. We couldn’t have fixed those bugs without your help!

Enjoy!
The Phoenix Viewer Project Inc.

  • Thank you for the updates! However, I still inevitably crash every time I attempt to upload a texture. I saw on the jira that this is a major bug and I was hoping that it was going to be fixed in this release.

    croiresl

    December 22, 2010

  • I was messaged quickly after posting my comment and the problem was easily fixed! Thanks for the help.

    croiresl

    December 22, 2010

  • This comment has been removed by the author.

    Fuki

    December 22, 2010

  • This comment has been removed by the author.

    Fuki

    December 22, 2010

  • The release notes say Full Display name support in groups, local chat, radar etc. so imagine my surprise whe I saw in IM the tab shows the username and in IM chat it still shows the username and NOT the display name. It is very confusing to half-implement this and I had hoped that was no longer the case…also there is no poiny in showing the display name again in the Friends list mouseover dialog. That really should be showing the username, not repeating the display name which is already visible. Love Phoenix…but sad this was not properly implemented in this ‘final’ release.

    Fuki

    December 22, 2010

  • Still getting the:

    “This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.”

    All 3 Windows versions provided have this exact same error message – Even after completely wiping Phoenix from my computer, registry, etc.

    Jessicka

    December 22, 2010

  • Jessicka: Use a new shortcut, not an old one from a previous install. That fixes that issue for most people.

    Fuki

    December 22, 2010

  • I did. I erase everything named (both file-name, and registry) named “phoenix” or “emerald” from my computer, and start fresh. I get that error every time with all three builds :/

    Jessicka

    December 22, 2010

  • Awesome. Thank you.

    Caps

    December 22, 2010

  • This is great – I love Phoenix – swear by it but there are still some things that are needed and when are they coming.

    1. The use of multiple tattoo layers. Some of the other viewers have this and it sure would be nice and make customizing your avi so much better.

    2. When are we going to get more groups – so many people are grouped out. There is talk that 40 groups is coming to SL but that you all don’t support that – boy it sure is needed.

    Thanks for all the hard work and the nice new release. Fingers crossed that many people’s wish list will see these changes too.

    SM

    Sabine

    December 22, 2010

  • angry master

    December 22, 2010

  • I am extremely disappointed that Phoenix no longer supports secondary attachment points… that’s why I use Phoenix… If I didn’t despise the new sl viewer style I would just go back to that… very disappointed.

    FairyQueen

    December 22, 2010

  • why its don`t save history in PC?

    chica

    December 22, 2010

  • FairyQueen, right click and select add, problem solved…double attachments were buggy and out-dated, phoenix has since moved onto the superior LL multi attach

    W

    December 22, 2010

  • Installed the new 818/SSE2 and until now it works nicely.
    Thank you for the good work :)

    Marjolaine

    December 22, 2010

  • @Sabine Phoenix does have support for 40 groups, when the Lab enables it. (Since 1.5.2.725) Debug settings: phoenix40GroupsSupport.

    Multi-layers are said to be harder (or maybe even impossible) to implement using the current viewer’s codebase (do you know any “traditional” viewers that have them?). They will be available in the coming viewer-2 based Phoenix.

    sandgirl

    December 22, 2010

  • @W
    Thank you for the info.. I have been out of world for a bit now and don’t keep up with LL developments as I don’t like their viewer. It’s nice to see that LL finally caught on to the little marvel of needing to have multi-attachment points.

    Again, ty for the info.

    FairyQueen

    December 23, 2010

  • Phoenix was stable when I first started using it a while back but for the last two nights I’ve been crashing right at log in. I updated to the 818 standard version to see if that would fix it, but I’m still having problems with crashing..

    porselinchild

    December 23, 2010

  • And still no Growl notifications :(

    nepenthe

    December 23, 2010

  • I am so excited. This is downloading now. Going slow must be a lot of us!

    I am actually looking forward to what the Phoenix team has in store to improve the V2 UI for us in firestorm!

    Mist

    December 23, 2010

  • When I updated Phoenix, I noticed certain prims looked whacked. o_O not sure if this is just me or if I’m doing something wrong. It’s consistent on prims that I own and other people’s builds.

    velvetroom

    December 23, 2010

  • i got the same issue, specially mega prims look whacked…. something is not good with this version.

    MY Nimbus

    December 23, 2010

  • Okay, I downloaded the SSE version for windows earlier today. It seems to work great but I’m seeing the program gobbling up a lot of memory after awhile.

    It finally crashed after running for 5 hours tonight – had been using around 500,000K just before the crash. My system only has 1 gig of ram so it was paging like mad anytime I accessed inventory.

    Wesley

    December 23, 2010

  • phoehnix latest version on windows vista does not start! it is terrible!!

    borg7of9

    December 23, 2010

  • fixed version does not work at all. same situation happened!

    borg7of9

    December 23, 2010

  • My bad…

    I just checked the download log, I downloaded the SSE2 version earlier today.

    Might have something to do with my problems.

    Downloading the linux version and will see how it goes…

    Wesley

    December 23, 2010

  • I know this must be a stupid question, and I apologize for asking, but what are Growl notifications?

    Running new SSE2 in Vista and it works fine – Tons of thanks.

    Granted, I don’t use ALL the bells a whistles, but what i do use is humming along nicely.

    Mewling

    December 23, 2010

  • is it me? or is there still some kind of bug?
    I took pics of my av and when i zoomed in i saw that the shape of my eyes and nose were kinda messed up (and it’s not the shape that’s doing it)

    KEVINN Draconia

    December 23, 2010

  • Ty Team Phoenix for the new viewer!!! I know all the work that went into this last build and we certainly appreciate it. It would be nice to explain to the non techie what the difference is between SSE and SEE2

    Michael Stephenson

    December 23, 2010

  • I’m sticking with 725 SSE2 for now, rendering times are a lot better the either 818 release

    Predreus

    December 24, 2010

  • This is my first comment on that blog. Thank you for the new Phoenix release and to allow SSE again.

    Ryou Yiyuan

    December 24, 2010

  • Oh! I downloaded the SSE version and the megaprim problems are fixed now. Hopefully :)

    velvetroom

    December 25, 2010

  • On Linux version of the Phoenix Viewer there is still the webkit plugin failure on media init. Copying related binaries over from 373 (the last known working ones) fixes this for me, but is dirty. I wonder how many testers there are for the Linux version?

    zhaarteth

    December 25, 2010

  • The Mac version also still has that webkit plugin failure! :(

    pc1271

    December 25, 2010

  • Don’t think the webkit *was* a fixed issue. I got it too, on the Windows “standard” version.

    Kagehi

    December 25, 2010

  • The RC was working fine for me except for not getting my notices and IMs when I logged into. Fast and smooth, no problems other than that. With this final release, I’m finding it runs slower than any viewer I’ve used yet, my inventory is going missing again, and I can’t set the location I want my cache to go; it just reverts back to a non-existent drive every time I close the Preferences window. Am I the only one? I’m deeply disappointed to think that this is the “final” release. If it is, I’ll have to go back to Imprudence and forget about all the new bells and whistles I was enjoying in the Phoenix Release Candidate as this version is nothing like it.

    Siwan

    December 26, 2010

  • I am having nothing but issues with this new update. My texture memory setting won’t save. All of my windows (chat, inventory, etc) go clear. I crash a lot on teleports. Didn’t happen like this before. One that doesn’t really bug me tho but it probably should be reported. Friends list names, the names show up as (???) firstname.lastname then never load unless you relog. I relog A LOT. I used to hardly ever have to relog. I sure hope the issues are fixed in the next update. I don’t like the other viewers.

    Lindsay Pinelli

    December 27, 2010

  • re: multiple layers – I thought that Kirsten had implemented them before viewer 2 was out, but I could be wrong?

    I do really wish that we didn’t have to wait for Firestorm for multiple layers. A lot of stuff in SL is coming out that makes not having it becoming a pain in the ass – like skins with the eyebrows on tattoo layers … if you also want to wear makeup, you’re screwed :/ I don’t like having to use SL’s official viewer just to layer up.

    Still, I’m extremely happy with Phoenix thus far. Thank you so much for making it! :)

    Xandra/Ruina Kessel

    December 27, 2010

  • One heartfelt plea for Firestorm… Keep the backward compatibility. I usually use the v2 dev daily for SL, but any opensim based grid I connect to that borks the world map. Make it revert to the old method for fetching map tiles if the MapServerURL key is blank. (Henri already made a patch to use the old maptile method as a fallback for snowglobe) If Firestorm has that kind of backwards compatibility to make it work with ALL grids then you’ll blow the linden viewer out of the water with it.

    Dave_B

    December 28, 2010

  • Welp. That’s what you get when the community support team plays dev.

    jeremy

    December 28, 2010

  • This new release of Phoenix is bad. I have never had a hard time with phoenix until this new release. I crash all the time now. I cant be in it for more then 2 minutes before I crash. I had to down grade.

    JennaRose

    December 29, 2010

  • This new release of Phoenix is bad. I have never had a hard time with phoenix until this new release. I crash all the time now. I cant be in it for more then 2 minutes before I crash. I had to down grade.

    JennaRose

    December 29, 2010

  • This comment has been removed by the author.

    Stephy Silvercloud

    December 29, 2010

  • er, delete my comment if possible, got it fixed, had a DUH moment sorry

    Stephy Silvercloud

    December 29, 2010

  • Whats up with the basic shaders… my windlight settings and the nams optimal skin settings are showing the sea as black with basic shaders enabled unless you turn your graphic right down to the lowest levels where basic shaders aren’t on anyway. Its not only the sea thats black but some of my eyelashes turn white as well.. never had this before on any viewer including emerald, emergence and phoenix until this update :-S

    JoeBloggs

    December 31, 2010

  • Does this update work for 64 bit now as well?

    Alessandra

    January 3, 2011

  • I have tried to download phoenix viewer several times, plus the fix an still keep receiving error massages, an it is being called a trojan an is deleted.
    Now what do I do, an how do I correct this
    Thank you

    pattyj

    January 3, 2011

  • I had to go out and buy a new hard drive because my old one went kaput finally… now when I try to open Phoenix after the install… I get
    “This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.”

    I keep trying to reinstall, I have deleted everything from folders and registry… yet it still does it. I don’t want to have to use Viewer 2 just to get on SL.

    Jessica

    January 4, 2011

  • Updated to Phoenix 1.5.2.818 today.. and found something. An unfriended contact bouncing around in my contact list… ZZZZHATEOF blah bla blah. I chased it around until I finally deleted it, and unfortunately a few of my contacts as well. What kindof bug is this and what is the fix or solution? Can this infest my harddrive? I was thinking to delete all contacts, uninstall Phoenix 1.5.2.818 and reinstall the previous version. What do I do?

    Sharopa

    January 14, 2011

  • “This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.” What am I doing wrong?

    Hecate

    February 16, 2011

  • Oh . .same deal as Jessica a couple posts up. New hard drive, reinstalled everything and got that message “This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem.”

    Hecate

    February 16, 2011

  • im using a dell desktop windows xp and every time i run phoenix this message states failed to load viewer beacause application configuration is incorrect reinstalling app may fix this problem ive reinstalled it a few times and resstarted my computer and this problems still happens what should i do?

    kdsharpe

    May 11, 2011

  • I am having the same problem as kdsharpe and others. I tried creating a new shortcut as directed and I am having the same problem. Can’t someone offer some help?

    Adams

    May 30, 2011

  • Sooooo…. same problem as adams etc.. anyone help?

    Lonnie

    August 14, 2011

  • my computer crashed last week and I had to reinstall windows… Now when I install firestorm or phoenix and then try to run it I get failed to start because the application configuration is incorrect. reinstalling it does NOT help and I’m not using old icons….. any thing????

    Unknown

    December 6, 2011

Leave a comment (NOTE: We cannot provide support or help in these blog comments. If you need or want help please contact our support team through the correct channels. See our support page for more information.)  

name*

email*

website

Submit comment